summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-06-10 14:43:38 +0200
committertv <tv@krebsco.de>2016-06-10 16:04:56 +0200
commitfed55eed93033a2eae440b45b5bf54f120d0ac8b (patch)
treed1afca7697320252e83d4f5c99ebaffed6fd6bda /tv/2configs/vim.nix
parent3b308d5ed92b4e12dca3a20c0c2811e2c407f47f (diff)
tv nix.vim: NixString can span multiple lines
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index c2f6c845..f6a5cc9c 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -218,7 +218,11 @@ let
syn match NixHPATH /\~\(\/[a-zA-Z0-9\.\_\-\+]\+\)\+/
syn match NixSPATH /<[a-zA-Z0-9\.\_\-\+]\+\(\/[a-zA-Z0-9\.\_\-\+]\+\)*>/
syn match NixURI /[a-zA-Z][a-zA-Z0-9\+\-\.]*:[a-zA-Z0-9\%\/\?\:\@\&\=\+\$\,\-\_\.\!\~\*\']\+/
- syn match NixSTRING /"\([^\\"]\|\\.\)*"/
+ syn region NixSTRING
+ \ matchgroup=NixSTRING
+ \ start='"'
+ \ skip='\\"'
+ \ end='"'
syn region NixIND_STRING
\ matchgroup=NixIND_STRING
\ start="'''"