summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-11-01 13:28:16 +0100
committertv <tv@shackspace.de>2015-11-01 13:28:16 +0100
commit9c36073e7b0081eaec37b0de232aeee2dcf5d8ab (patch)
tree85b7f302dba74f73397e99bc80eefad08bd98fcd /tv/2configs/vim.nix
parent2977f6d2910528bd7b3c78ae614aebff18dd4874 (diff)
tv base: import vim
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index 7eb2eb13..74eee0a3 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -7,6 +7,13 @@ let
vim'
];
+ # Nano really is just a stupid name for Vim.
+ # Note: passing just pkgs.vim to cvs to not rebuild it all the time
+ nixpkgs.config.packageOverrides = pkgs: {
+ cvs = pkgs.cvs.override { nano = pkgs.vim; };
+ nano = vim';
+ };
+
environment.variables.EDITOR = mkForce "vim";
};