summaryrefslogtreecommitdiffstats
path: root/tv/2configs/ssh.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-07-23 12:18:46 +0200
committertv <tv@krebsco.de>2016-07-23 12:55:04 +0200
commitd80762acc8f626004cc8bfa51e7a3927f351d067 (patch)
treeafd1ecad905b6b764c8086595d128b0d6f8530ee /tv/2configs/ssh.nix
parentad816aaa281094fc4fde1755de618440a5a1df28 (diff)
tv ssh: init
Diffstat (limited to 'tv/2configs/ssh.nix')
-rw-r--r--tv/2configs/ssh.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/tv/2configs/ssh.nix b/tv/2configs/ssh.nix
new file mode 100644
index 00000000..7bf58342
--- /dev/null
+++ b/tv/2configs/ssh.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+
+with config.krebs.lib;
+
+{
+ # Override NixOS's "Allow DSA keys for now."
+ environment.etc."ssh/ssh_config".text = mkForce ''
+ AddressFamily ${if config.networking.enableIPv6 then "any" else "inet"}
+
+ ${optionalString config.programs.ssh.setXAuthLocation ''
+ XAuthLocation ${pkgs.xorg.xauth}/bin/xauth
+ ''}
+
+ ForwardX11 ${if config.programs.ssh.forwardX11 then "yes" else "no"}
+
+ ${config.programs.ssh.extraConfig}
+ '';
+
+ programs.ssh = {
+ extraConfig = ''
+ UseRoaming no
+ '';
+ startAgent = false;
+ };
+}