summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/w110er.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-12-13 09:29:58 +0100
committermakefu <github@syntax-fehler.de>2021-12-13 09:29:58 +0100
commited065e8add0376384b8f23a016f0fedab13f7fd2 (patch)
tree1e596ac0432bb6d085d2861efee5f54bdea37e75 /tv/2configs/hw/w110er.nix
parentd424c3f6af7c505d5ad64210d0a1b59af7483916 (diff)
parentf2533d88924feb48834a07c4dc1e82cd21acd025 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'tv/2configs/hw/w110er.nix')
-rw-r--r--tv/2configs/hw/w110er.nix26
1 files changed, 15 insertions, 11 deletions
diff --git a/tv/2configs/hw/w110er.nix b/tv/2configs/hw/w110er.nix
index 818d1aca..09dd9a49 100644
--- a/tv/2configs/hw/w110er.nix
+++ b/tv/2configs/hw/w110er.nix
@@ -1,7 +1,6 @@
-with import <stockholm/lib>;
-{ pkgs, ... }:
-
-{
+{ pkgs, ... }: let
+ lib = import <stockholm/lib>;
+in {
imports = [
../smartd.nix
{
@@ -16,6 +15,18 @@ with import <stockholm/lib>;
# "nvidia-settings"
#];
}
+
+ {
+ nix.buildCores = 4;
+ nix.maxJobs = 4;
+ }
+ (if lib.versionAtLeast (lib.versions.majorMinor lib.version) "21.11" then {
+ nix.daemonCPUSchedPolicy = "batch";
+ nix.daemonIOSchedPriority = 1;
+ } else {
+ nix.daemonIONiceLevel = 1;
+ nix.daemonNiceLevel = 1;
+ })
];
boot.extraModprobeConfig = ''
@@ -35,13 +46,6 @@ with import <stockholm/lib>;
networking.wireless.enable = true;
- nix = {
- buildCores = 4;
- maxJobs = 4;
- daemonIONiceLevel = 1;
- daemonNiceLevel = 1;
- };
-
services.logind.extraConfig = ''
HandleHibernateKey=ignore
HandleLidSwitch=ignore