summaryrefslogtreecommitdiffstats
path: root/tv/2configs/htop.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-03-07 22:40:36 +0100
committertv <tv@krebsco.de>2017-03-07 22:40:36 +0100
commit653d023c2bd02e9d2eac0c8e76b316ab0c6871e7 (patch)
treefaeb1ffedd2e120caa1bdce55435d2b75fe28c76 /tv/2configs/htop.nix
parent218c58ef333e6968caa846612bdee162517b3b53 (diff)
tv htop: init
Diffstat (limited to 'tv/2configs/htop.nix')
-rw-r--r--tv/2configs/htop.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/tv/2configs/htop.nix b/tv/2configs/htop.nix
new file mode 100644
index 00000000..409df251
--- /dev/null
+++ b/tv/2configs/htop.nix
@@ -0,0 +1,40 @@
+{ pkgs, ... }:
+
+with import <stockholm/lib>;
+
+{
+ nixpkgs.config.packageOverrides = super: {
+ htop = pkgs.concat "htop" [
+ super.htop
+ (pkgs.writeDashBin "htop" ''
+ export HTOPRC=${pkgs.writeText "htoprc" ''
+ fields=0 48 17 18 38 39 40 2 46 47 49 1
+ sort_key=46
+ sort_direction=1
+ hide_threads=0
+ hide_kernel_threads=1
+ hide_userland_threads=0
+ shadow_other_users=1
+ show_thread_names=1
+ show_program_path=1
+ highlight_base_name=1
+ highlight_megabytes=1
+ highlight_threads=1
+ tree_view=1
+ header_margin=1
+ detailed_cpu_time=0
+ cpu_count_from_zero=0
+ update_process_names=0
+ account_guest_in_cpu_meter=1
+ color_scheme=0
+ delay=15
+ left_meters=LeftCPUs2 RightCPUs2 Memory Swap
+ left_meter_modes=1 1 1 1
+ right_meters=Uptime Tasks LoadAverage Battery
+ right_meter_modes=2 2 2 2
+ ''}
+ exec ${super.htop}/bin/htop "$@"
+ '')
+ ];
+ };
+}