summaryrefslogtreecommitdiffstats
path: root/tv/2configs/backup.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-13 17:56:59 +0100
committertv <tv@krebsco.de>2016-02-13 17:56:59 +0100
commitde4260a6a2b77aeb8115167ee63c1b20facd5b6a (patch)
treef3fa9b1ce28ccc8f4f9e02fa791173caf540c4f9 /tv/2configs/backup.nix
parent0257acf93a7cfc91fa65b0d00dcf7f70caa9a33b (diff)
tv backup: add xu-test-*
Diffstat (limited to 'tv/2configs/backup.nix')
-rw-r--r--tv/2configs/backup.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tv/2configs/backup.nix b/tv/2configs/backup.nix
index 6c90709a..57f299eb 100644
--- a/tv/2configs/backup.nix
+++ b/tv/2configs/backup.nix
@@ -26,5 +26,28 @@ with lib;
yearly = { format = "%Y"; };
};
};
+ } // mapAttrs (_: recursiveUpdate {
+ snapshots = {
+ minutely = { format = "%Y-%m-%dT%H:%M"; retain = 3; };
+ hourly = { format = "%Y-%m-%dT%H"; retain = 3; };
+ daily = { format = "%Y-%m-%d"; retain = 3; };
+ };
+ startAt = null;
+ }) {
+ xu-test-push-xu = {
+ method = "push";
+ src = { host = config.krebs.hosts.xu; path = "/tmp/xu-bku-test-data"; };
+ dst = { host = config.krebs.hosts.xu; path = "/bku/xu-test-push"; };
+ };
+ xu-test-pull-xu = {
+ method = "pull";
+ src = { host = config.krebs.hosts.xu; path = "/tmp/xu-bku-test-data"; };
+ dst = { host = config.krebs.hosts.xu; path = "/bku/xu-test-pull"; };
+ };
+ xu-test-push-wu = {
+ method = "push";
+ src = { host = config.krebs.hosts.xu; path = "/tmp/xu-bku-test-data"; };
+ dst = { host = config.krebs.hosts.wu; path = "/bku/xu-test-push"; };
+ };
};
}