summaryrefslogtreecommitdiffstats
path: root/nin/krops.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-10-14 09:25:42 +0200
committermakefu <github@syntax-fehler.de>2019-10-14 09:25:42 +0200
commitc288a54f76a6c556fbdc50c0b5d7793edb2c7a34 (patch)
tree4d649db7fb911475f17a9c474b6b24babdbed0bb /nin/krops.nix
parent0459d44921fab70ad876ffe40d61283da2e6be06 (diff)
parentc8e29c89bc2d5fa254aeb0a98207c4fa47b5aa3c (diff)
Merge remote-tracking branch 'lass/19.09' into 19.09
Diffstat (limited to 'nin/krops.nix')
-rw-r--r--nin/krops.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nin/krops.nix b/nin/krops.nix
new file mode 100644
index 00000000..52aeb847
--- /dev/null
+++ b/nin/krops.nix
@@ -0,0 +1,35 @@
+{ name }: let
+ inherit (import ../krebs/krops.nix { inherit name; })
+ krebs-source
+ lib
+ pkgs
+ ;
+
+ source = { test }: lib.evalSource [
+ (krebs-source { test = test; })
+ {
+ nixos-config.symlink = "stockholm/nin/1systems/${name}/config.nix";
+ secrets = if test then {
+ file = toString ./0tests/dummysecrets;
+ } else {
+ pass = {
+ dir = "${lib.getEnv "HOME"}/.password-store";
+ name = "hosts/${name}";
+ };
+ };
+ }
+ ];
+
+in {
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
+ deploy = pkgs.krops.writeDeploy "${name}-deploy" {
+ source = source { test = false; };
+ target = "root@${name}/var/src";
+ };
+
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)
+ test = { target }: pkgs.krops.writeTest "${name}-test" {
+ inherit target;
+ source = source { test = true; };
+ };
+}