summaryrefslogtreecommitdiffstats
path: root/nin/2configs/weechat.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-10-14 09:25:42 +0200
committermakefu <github@syntax-fehler.de>2019-10-14 09:25:42 +0200
commitc288a54f76a6c556fbdc50c0b5d7793edb2c7a34 (patch)
tree4d649db7fb911475f17a9c474b6b24babdbed0bb /nin/2configs/weechat.nix
parent0459d44921fab70ad876ffe40d61283da2e6be06 (diff)
parentc8e29c89bc2d5fa254aeb0a98207c4fa47b5aa3c (diff)
Merge remote-tracking branch 'lass/19.09' into 19.09
Diffstat (limited to 'nin/2configs/weechat.nix')
-rw-r--r--nin/2configs/weechat.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nin/2configs/weechat.nix b/nin/2configs/weechat.nix
new file mode 100644
index 00000000..6c0fb313
--- /dev/null
+++ b/nin/2configs/weechat.nix
@@ -0,0 +1,21 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (import <stockholm/lib>) genid;
+in {
+ krebs.per-user.chat.packages = with pkgs; [
+ mosh
+ weechat
+ tmux
+ ];
+
+ users.extraUsers.chat = {
+ home = "/home/chat";
+ uid = genid "chat";
+ useDefaultShell = true;
+ createHome = true;
+ openssh.authorizedKeys.keys = [
+ config.krebs.users.nin.pubkey
+ ];
+ };
+}