summaryrefslogtreecommitdiffstats
path: root/nin/2configs/copyq.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-04-22 00:30:37 +0200
committermakefu <github@syntax-fehler.de>2020-04-22 00:30:37 +0200
commitcb7ea9d84af46b606e5daa1252c60eb210d7e576 (patch)
tree5166a62dc73c45b3cd3b996078913588d1844266 /nin/2configs/copyq.nix
parent0b371833e9ef68fd891fac65a657d8e38b5b3fad (diff)
parentc49867b40327f83a18b956404875637ca379c1ba (diff)
Merge remote-tracking branch 'lass/20.03' into 20.03
Diffstat (limited to 'nin/2configs/copyq.nix')
-rw-r--r--nin/2configs/copyq.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/nin/2configs/copyq.nix b/nin/2configs/copyq.nix
deleted file mode 100644
index 0616c402..00000000
--- a/nin/2configs/copyq.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{ config, pkgs, ... }:
-with import <stockholm/lib>;
-let
- copyqConfig = pkgs.writeDash "copyq-config" ''
- ${pkgs.copyq}/bin/copyq config check_clipboard true
- ${pkgs.copyq}/bin/copyq config check_selection true
- ${pkgs.copyq}/bin/copyq config copy_clipboard true
- ${pkgs.copyq}/bin/copyq config copy_selection true
-
- ${pkgs.copyq}/bin/copyq config activate_closes true
- ${pkgs.copyq}/bin/copyq config clipboard_notification_lines 0
- ${pkgs.copyq}/bin/copyq config clipboard_tab clipboard
- ${pkgs.copyq}/bin/copyq config disable_tray true
- ${pkgs.copyq}/bin/copyq config hide_tabs true
- ${pkgs.copyq}/bin/copyq config hide_toolbar true
- ${pkgs.copyq}/bin/copyq config item_popup_interval true
- ${pkgs.copyq}/bin/copyq config maxitems 1000
- ${pkgs.copyq}/bin/copyq config move true
- ${pkgs.copyq}/bin/copyq config text_wrap true
- '';
-in {
- systemd.user.services.copyq = {
- after = [ "graphical.target" ];
- wants = [ "graphical.target" ];
- wantedBy = [ "default.target" ];
- environment = {
- DISPLAY = ":0";
- };
- serviceConfig = {
- SyslogIdentifier = "copyq";
- ExecStart = "${pkgs.copyq}/bin/copyq";
- ExecStartPost = copyqConfig;
- Restart = "always";
- RestartSec = "2s";
- StartLimitBurst = 0;
- };
- };
-}