summaryrefslogtreecommitdiffstats
path: root/nin/2configs/copyq.nix
diff options
context:
space:
mode:
authornin <nin@c-base.org>2019-09-25 19:42:41 +0200
committertv <tv@krebsco.de>2019-09-25 21:36:01 +0200
commit7050df8789e7e7bfff93dabdcb3897ec6611cb1a (patch)
tree01730f74bc982bff127d68e29b1cd7c3c8d836c7 /nin/2configs/copyq.nix
parentc75710a489417def207a55cca82f9225164da84a (diff)
Revert "remove nin"
This reverts commit 6b08d5aa46adc80d8a1ab4ed1d3e320c61a19f01.
Diffstat (limited to 'nin/2configs/copyq.nix')
-rw-r--r--nin/2configs/copyq.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/nin/2configs/copyq.nix b/nin/2configs/copyq.nix
new file mode 100644
index 00000000..0616c402
--- /dev/null
+++ b/nin/2configs/copyq.nix
@@ -0,0 +1,38 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+let
+ copyqConfig = pkgs.writeDash "copyq-config" ''
+ ${pkgs.copyq}/bin/copyq config check_clipboard true
+ ${pkgs.copyq}/bin/copyq config check_selection true
+ ${pkgs.copyq}/bin/copyq config copy_clipboard true
+ ${pkgs.copyq}/bin/copyq config copy_selection true
+
+ ${pkgs.copyq}/bin/copyq config activate_closes true
+ ${pkgs.copyq}/bin/copyq config clipboard_notification_lines 0
+ ${pkgs.copyq}/bin/copyq config clipboard_tab clipboard
+ ${pkgs.copyq}/bin/copyq config disable_tray true
+ ${pkgs.copyq}/bin/copyq config hide_tabs true
+ ${pkgs.copyq}/bin/copyq config hide_toolbar true
+ ${pkgs.copyq}/bin/copyq config item_popup_interval true
+ ${pkgs.copyq}/bin/copyq config maxitems 1000
+ ${pkgs.copyq}/bin/copyq config move true
+ ${pkgs.copyq}/bin/copyq config text_wrap true
+ '';
+in {
+ systemd.user.services.copyq = {
+ after = [ "graphical.target" ];
+ wants = [ "graphical.target" ];
+ wantedBy = [ "default.target" ];
+ environment = {
+ DISPLAY = ":0";
+ };
+ serviceConfig = {
+ SyslogIdentifier = "copyq";
+ ExecStart = "${pkgs.copyq}/bin/copyq";
+ ExecStartPost = copyqConfig;
+ Restart = "always";
+ RestartSec = "2s";
+ StartLimitBurst = 0;
+ };
+ };
+}