summaryrefslogtreecommitdiffstats
path: root/nin/2configs/copyq.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-10-14 09:25:42 +0200
committermakefu <github@syntax-fehler.de>2019-10-14 09:25:42 +0200
commitc288a54f76a6c556fbdc50c0b5d7793edb2c7a34 (patch)
tree4d649db7fb911475f17a9c474b6b24babdbed0bb /nin/2configs/copyq.nix
parent0459d44921fab70ad876ffe40d61283da2e6be06 (diff)
parentc8e29c89bc2d5fa254aeb0a98207c4fa47b5aa3c (diff)
Merge remote-tracking branch 'lass/19.09' into 19.09
Diffstat (limited to 'nin/2configs/copyq.nix')
-rw-r--r--nin/2configs/copyq.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/nin/2configs/copyq.nix b/nin/2configs/copyq.nix
new file mode 100644
index 00000000..0616c402
--- /dev/null
+++ b/nin/2configs/copyq.nix
@@ -0,0 +1,38 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+let
+ copyqConfig = pkgs.writeDash "copyq-config" ''
+ ${pkgs.copyq}/bin/copyq config check_clipboard true
+ ${pkgs.copyq}/bin/copyq config check_selection true
+ ${pkgs.copyq}/bin/copyq config copy_clipboard true
+ ${pkgs.copyq}/bin/copyq config copy_selection true
+
+ ${pkgs.copyq}/bin/copyq config activate_closes true
+ ${pkgs.copyq}/bin/copyq config clipboard_notification_lines 0
+ ${pkgs.copyq}/bin/copyq config clipboard_tab clipboard
+ ${pkgs.copyq}/bin/copyq config disable_tray true
+ ${pkgs.copyq}/bin/copyq config hide_tabs true
+ ${pkgs.copyq}/bin/copyq config hide_toolbar true
+ ${pkgs.copyq}/bin/copyq config item_popup_interval true
+ ${pkgs.copyq}/bin/copyq config maxitems 1000
+ ${pkgs.copyq}/bin/copyq config move true
+ ${pkgs.copyq}/bin/copyq config text_wrap true
+ '';
+in {
+ systemd.user.services.copyq = {
+ after = [ "graphical.target" ];
+ wants = [ "graphical.target" ];
+ wantedBy = [ "default.target" ];
+ environment = {
+ DISPLAY = ":0";
+ };
+ serviceConfig = {
+ SyslogIdentifier = "copyq";
+ ExecStart = "${pkgs.copyq}/bin/copyq";
+ ExecStartPost = copyqConfig;
+ Restart = "always";
+ RestartSec = "2s";
+ StartLimitBurst = 0;
+ };
+ };
+}