summaryrefslogtreecommitdiffstats
path: root/mb/3modules/hosts.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-04-28 13:46:00 +0200
committerlassulus <lassulus@lassul.us>2019-04-28 13:46:00 +0200
commit2f8a55268c75142a19a58fe3752d197077a223b4 (patch)
treee2df9faec64cfbfdc2d57a653b6e928fb2ee81b4 /mb/3modules/hosts.nix
parentc483c69ba183772bfd2e5a2972bfd7cbc550fba3 (diff)
parent3dc61a8f2d525f7f6c1260ca97a918f78242cb1c (diff)
Merge branch 'mb'
Diffstat (limited to 'mb/3modules/hosts.nix')
-rw-r--r--mb/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/mb/3modules/hosts.nix b/mb/3modules/hosts.nix
new file mode 100644
index 00000000..5dc9b5ca
--- /dev/null
+++ b/mb/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with import <stockholm/lib>;
+
+{
+ options.mb.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "mb" && host.ci)
+ config.krebs.hosts;
+ };
+}