summaryrefslogtreecommitdiffstats
path: root/mb/1systems/gr33n/hardware-configuration.nix
diff options
context:
space:
mode:
authormagenbluten <magenbluten@codemonkey.cc>2019-05-21 19:43:40 +0200
committermagenbluten <magenbluten@codemonkey.cc>2019-05-21 19:43:40 +0200
commitc74d86cf6a1299ba0a11fcfb2341a8632b147420 (patch)
treef7b4107bd8959b25e46addc2afd8098a6ef36d4e /mb/1systems/gr33n/hardware-configuration.nix
parent7736272ac122ef616a253a8732bcddbddb031047 (diff)
mb: add new machines
Diffstat (limited to 'mb/1systems/gr33n/hardware-configuration.nix')
-rw-r--r--mb/1systems/gr33n/hardware-configuration.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/mb/1systems/gr33n/hardware-configuration.nix b/mb/1systems/gr33n/hardware-configuration.nix
new file mode 100644
index 00000000..1d13b8dc
--- /dev/null
+++ b/mb/1systems/gr33n/hardware-configuration.nix
@@ -0,0 +1,37 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "nvme" "usb_storage" "usbhid" "sd_mod" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ boot.initrd.mdadmConf = ''
+ ARRAY /dev/md0 level=raid6 num-devices=4 metadata=1.2 name=gr33n:0 UUID=5b715fd9:0be6bfa6:19f07db4:c16836d6
+ devices=/dev/sda1,/dev/sdb1,/dev/sdc1,/dev/sdd1
+ '';
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/a9f2c19b-f60f-450c-87f1-146a54c4198b";
+ fsType = "ext4";
+ };
+ fileSystems."/storage" =
+ { device = "/dev/disk/by-label/storage";
+ fsType = "ext4";
+ };
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/93EB-BCA3";
+ fsType = "vfat";
+ };
+
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}