summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/ratt/default.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-06-07 15:46:12 +0200
committerlassulus <lassulus@lassul.us>2022-06-07 15:46:12 +0200
commitb3786c3a74fce6a742649c37ab2ad1255f5864bf (patch)
treea5453da91d868781b2339722a4e7bf588993ac09 /makefu/5pkgs/ratt/default.nix
parente6f67aa910f78ecf75f3a47a0794497148c60c2b (diff)
parent53855cd2d0dadb159215c5ed12e6d0be02dca98b (diff)
Merge remote-tracking branch 'gum/22.05'
Diffstat (limited to 'makefu/5pkgs/ratt/default.nix')
-rw-r--r--makefu/5pkgs/ratt/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/makefu/5pkgs/ratt/default.nix b/makefu/5pkgs/ratt/default.nix
new file mode 100644
index 00000000..57ea545b
--- /dev/null
+++ b/makefu/5pkgs/ratt/default.nix
@@ -0,0 +1,26 @@
+{ buildGoModule, fetchFromSourcehut, lib }:
+buildGoModule rec {
+ pname = "ratt";
+ version = "unstable-2022-05-09";
+
+ src = fetchFromSourcehut {
+ owner = "~ghost08";
+ repo = "ratt";
+ rev = "bf539e1cb04017f5e9d248a8e5f7a6f22f77d06e";
+ sha256 = "0pfz6wnmpwabklayah3bddxkhvg64f5hfyvzkv3xfqpw8c70jdll";
+ };
+
+ proxyVendor = true;
+ vendorSha256 = "sha256-901xkzF/p/kUy7tZELwNhgepRDScUeWQM3isy7APuik=";
+
+ # tests try to access the internet to scrape websites
+ doCheck = false;
+
+ meta = with lib; {
+ description = "A tool for converting websites to rss/atom feeds";
+ homepage = "https://git.sr.ht/~ghost08/ratt";
+ license = licenses.mit;
+ maintainers = with maintainers; [ kmein ];
+ platforms = platforms.linux ++ platforms.darwin;
+ };
+}