summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/prison-break/default.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-04-09 20:12:06 +0200
committerjeschli <jeschli@gmail.com>2019-04-09 20:12:06 +0200
commita4be985644762dcc2750a366db5780687690ef7d (patch)
tree5bc270cec7c01b986cd146769bc94bf2268c4113 /makefu/5pkgs/prison-break/default.nix
parentcb03267e0c3fd3bfa4beaa454f8986856a93963f (diff)
parent7e1b197dab13d024ba491c96dc959306324943c0 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'makefu/5pkgs/prison-break/default.nix')
-rw-r--r--makefu/5pkgs/prison-break/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/makefu/5pkgs/prison-break/default.nix b/makefu/5pkgs/prison-break/default.nix
new file mode 100644
index 00000000..f86ac376
--- /dev/null
+++ b/makefu/5pkgs/prison-break/default.nix
@@ -0,0 +1,20 @@
+{pkgs, fetchFromGitHub}:
+with pkgs.python3.pkgs;
+
+buildPythonPackage rec {
+ pname = "prison-break";
+ version = "0.1.0";
+ src = fetchFromGitHub {
+ owner = "makefu";
+ repo = pname;
+ rev = "5eed6371e151e716faafa054e005bd98d77b4b5d";
+ sha256 = "170zs9grbgkx83ghg6pm13v7vhi604y44j550ypp2x26nidaw63j";
+ };
+ propagatedBuildInputs = [
+ docopt
+ requests
+ beautifulsoup4
+ (callPackage ./straight-plugin.nix {})
+ ];
+ checkInputs = [ black ];
+}