summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/logstash-output-exec
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-08-16 12:03:32 +0200
committermakefu <github@syntax-fehler.de>2017-08-16 12:31:46 +0200
commit06a65dd592a62663b15547796b6f11fddb205b31 (patch)
tree21f2d720776a37ca3875937786e217cfa7bebfe3 /makefu/5pkgs/logstash-output-exec
parent8f14ff2f54167c8505de82f65d640a1bb0018f17 (diff)
ma 5pkgs: cleanup
Diffstat (limited to 'makefu/5pkgs/logstash-output-exec')
-rw-r--r--makefu/5pkgs/logstash-output-exec/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/makefu/5pkgs/logstash-output-exec/default.nix b/makefu/5pkgs/logstash-output-exec/default.nix
new file mode 100644
index 00000000..d1de851c
--- /dev/null
+++ b/makefu/5pkgs/logstash-output-exec/default.nix
@@ -0,0 +1,32 @@
+{ pkgs, stdenv, lib, fetchFromGitHub }:
+
+
+# TODO: requires ftw ruby package
+stdenv.mkDerivation rec {
+ name = "logstash-input-github-${version}";
+ version = "3.1.0";
+
+ src = fetchFromGitHub {
+ owner = "logstash-plugins";
+ repo = "logstash-output-exec";
+ rev = "v${version}";
+ sha256 = "0ix5w9l6hrbjaymkh7fzymjvpkiias3hs0l77zdpcwdaa6cz53nf";
+ };
+
+ dontBuild = true;
+ dontPatchELF = true;
+ dontStrip = true;
+ dontPatchShebangs = true;
+ installPhase = ''
+ mkdir -p $out/logstash
+ cp -r lib/* $out
+ '';
+
+ meta = with lib; {
+ description = "logstash output plugin";
+ homepage = https://github.com/logstash-plugins/logstash-output-exec;
+ license = stdenv.lib.licenses.asl20;
+ platforms = stdenv.lib.platforms.unix;
+ maintainers = with maintainers; [ makefu ];
+ };
+}