summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/ampel/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-02-06 11:56:36 +0100
committermakefu <github@syntax-fehler.de>2018-02-06 11:57:31 +0100
commit72f440fdb567b8000ec72aefa6d3e74734c11c9e (patch)
treea86bea629edd48b775bacbd8789d6cabb4e842ab /makefu/5pkgs/ampel/default.nix
parentef3a0dcff538c850c25b46165ed70c899873bece (diff)
ma omo.r: init google-muell
Diffstat (limited to 'makefu/5pkgs/ampel/default.nix')
-rw-r--r--makefu/5pkgs/ampel/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/5pkgs/ampel/default.nix b/makefu/5pkgs/ampel/default.nix
new file mode 100644
index 00000000..86518b9b
--- /dev/null
+++ b/makefu/5pkgs/ampel/default.nix
@@ -0,0 +1,27 @@
+{ lib, pkgs, fetchFromGitHub, ... }:
+
+with pkgs.python3Packages;buildPythonPackage rec {
+ name = "ampel-${version}";
+ version = "0.2";
+
+ propagatedBuildInputs = [
+ docopt
+ paho-mqtt
+ requests
+ pytz
+ influxdb
+ httplib2
+ google_api_python_client
+ ];
+
+ src = pkgs.fetchgit {
+ url = "http://cgit.euer.krebsco.de/ampel";
+ rev = "d8a0250";
+ sha256 = "0n36lc17ca5db6pl6dswdqd5w9f881rfqck9yc4w33a5qpsxj85f";
+ };
+ meta = {
+ homepage = http://cgit.euer.krebsco.de/ampel;
+ description = "change colors of rgb cubes";
+ license = lib.licenses.asl20;
+ };
+}