summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/bump-distrowatch.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-12-17 12:33:57 +0100
committermakefu <github@syntax-fehler.de>2018-12-17 12:34:00 +0100
commit87c62a2650c987f215dd979676c8d3426a47db72 (patch)
tree00e73b140fbbc3a61cd655f4df6aa612208240c1 /makefu/3modules/bump-distrowatch.nix
parent62e90729acb11b9b9eeee373048f9b338fe86a0e (diff)
ma bump-distrowatch: init
Diffstat (limited to 'makefu/3modules/bump-distrowatch.nix')
-rw-r--r--makefu/3modules/bump-distrowatch.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/makefu/3modules/bump-distrowatch.nix b/makefu/3modules/bump-distrowatch.nix
new file mode 100644
index 00000000..18426cdc
--- /dev/null
+++ b/makefu/3modules/bump-distrowatch.nix
@@ -0,0 +1,31 @@
+{ config, lib, pkgs, ... }:
+
+let
+ cfg = config.makefu.distrobump;
+
+ imp = {
+ systemd.services.distrobump = {
+ after = [ "network.target" ];
+ wantedBy = [ "multi-user.target" ];
+ path = [ pkgs.curl ];
+ restartIfChanged = false;
+ startAt = "daily";
+ serviceConfig = {
+ PrivateTmp = true;
+ Type = "oneshot";
+ ExecStart = pkgs.writeDash "bump-distrowatch" ''
+ set -euf
+ UA='Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0'
+ curl -Lvc /tmp/cookie.jar -A "$UA" 'https://distrowatch.com/' >/dev/null
+ sleep $(shuf -i 3-15 -n1).$(shuf -i 0-9 -n1)
+ curl -Lvc /tmp/cookie.jar -A "$UA" -e 'https://distrowatch.com/' 'https://distrowatch.com/nixos?frphr' >/dev/null
+ '';
+ RandomizedDelaySec = 28800;
+ };
+ };
+ };
+in
+{
+ options.makefu.distrobump.enable = lib.mkEnableOption "distrobump";
+ config = lib.mkIf cfg.enable imp;
+}