summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/tools/dev.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-04-08 17:13:47 +0200
committerlassulus <lassulus@lassul.us>2019-04-08 17:13:47 +0200
commit8df36824c35e0573c966b355264816dbef63a05b (patch)
tree2e757d9146b1e22c5f3e1c8426bd2ad8fc099dfd /makefu/2configs/tools/dev.nix
parent9e7729def580d83bc439985616f8c5d7162bcd48 (diff)
parent2f53271af0fda00bdc452c2bc5e569f064f562f6 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/tools/dev.nix')
-rw-r--r--makefu/2configs/tools/dev.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/makefu/2configs/tools/dev.nix b/makefu/2configs/tools/dev.nix
index fe25bd49..23da9d57 100644
--- a/makefu/2configs/tools/dev.nix
+++ b/makefu/2configs/tools/dev.nix
@@ -2,10 +2,15 @@
{
users.users.makefu.packages = with pkgs;[
- python3
- python3Packages.pyserial
+ (python3.withPackages(ps: [
+ ps.python-language-server
+ # the following plugins are optional, they provide type checking, import sorting and code formatting
+ ps.pyls-mypy ps.pyls-isort ps.pyls-black
+ ps.virtualenv
+ ]))
picocom
- python3Packages.virtualenv
+ python3.pkgs.pyserial
+ python3.pkgs.virtualenv
# embedded
gi
flashrom
@@ -26,6 +31,6 @@
nix-review
# git-related
tig
- init-host
+ (pkgs.callPackage ./init-host {})
];
}