summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/music.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-12-24 23:58:59 +0100
committermakefu <github@syntax-fehler.de>2022-12-24 23:58:59 +0100
commited1690d79318d61b10a8ea881989a4d2708c9b42 (patch)
treed6f7fb35927b08fe82a4418fd1830384183de65b /makefu/2configs/home/music.nix
parent2f14e6f8426c2b817aa1bcafd4a21e2b977cd64f (diff)
ma home: enable minidlna for testing, cleanup
Diffstat (limited to 'makefu/2configs/home/music.nix')
-rw-r--r--makefu/2configs/home/music.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/makefu/2configs/home/music.nix b/makefu/2configs/home/music.nix
index 205b47fe..f3b9f50f 100644
--- a/makefu/2configs/home/music.nix
+++ b/makefu/2configs/home/music.nix
@@ -9,7 +9,8 @@ in
MusicFolder = "/media/cryptX/music/kinder";
Address = "0.0.0.0";
};
- systemd.services.navidrome.after = [ "media-cryptX.mount" ];
+ systemd.services.navidrome.after = [ "media-cryptX.mount" "cryptsetup.target"
+"local-fs.target" "remote-fs.target" ];
state = [ "/var/lib/navidrome" ];
# networking.firewall.allowedTCPPorts = [ 4040 ];
@@ -27,4 +28,11 @@ in
locations."/".proxyWebsockets = true;
};
networking.firewall.allowedTCPPorts = [ port ];
+ # also configure dlna
+ services.minidlna.enable = true;
+ services.minidlna.settings = {
+ inotify = "yes";
+ friendly_name = "omo";
+ media_dir = [ "A,/media/cryptX/music" ];
+ };
}