summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/sensor/outside.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-02-05 17:34:44 +0100
committermakefu <github@syntax-fehler.de>2020-02-05 17:34:44 +0100
commitd31fbfe31ee26b70f13c93d910f5ce0d3ce1d8c2 (patch)
tree9ea97bb39e60eda600d195ec80a672700742a0fa /makefu/2configs/ham/sensor/outside.nix
parent89032b3ac2aff2373377ef442804e90db9694c91 (diff)
ma 2/homeautomation -> 2/ham
avoid overlapping autocomplete with home-manager
Diffstat (limited to 'makefu/2configs/ham/sensor/outside.nix')
-rw-r--r--makefu/2configs/ham/sensor/outside.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/makefu/2configs/ham/sensor/outside.nix b/makefu/2configs/ham/sensor/outside.nix
new file mode 100644
index 00000000..8436b8de
--- /dev/null
+++ b/makefu/2configs/ham/sensor/outside.nix
@@ -0,0 +1,26 @@
+{lib,...}: [
+ { platform = "darksky";
+ api_key = lib.removeSuffix "\n"
+ (builtins.readFile <secrets/hass/darksky.apikey>);
+ language = "de";
+ monitored_conditions = [
+ "summary" "icon"
+ "nearest_storm_distance" "precip_probability"
+ "precip_intensity"
+ "temperature" # "temperature_high" "temperature_low"
+ "apparent_temperature"
+ "hourly_summary" # next 24 hours text
+ "humidity"
+ "pressure"
+ "uv_index"
+ ];
+ units = "si" ;
+ scan_interval = "00:30:00";
+ }
+ { platform = "luftdaten";
+ name = "Muehlhausen";
+ show_on_map = true;
+ sensor_id = "679";
+ sensors.monitored_conditions = [ "P1" "P2" ];
+ }
+ ]