summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/multi/the_playlist.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-04-19 21:24:52 +0200
committermakefu <github@syntax-fehler.de>2020-04-19 21:24:52 +0200
commit0b371833e9ef68fd891fac65a657d8e38b5b3fad (patch)
treec5c9e35f73713fc518f43fc9837e5a24c255917f /makefu/2configs/ham/multi/the_playlist.nix
parent2dfadc18518900d48bd367c18d894a91b7bf2a77 (diff)
ma ham: add the_playlist
Diffstat (limited to 'makefu/2configs/ham/multi/the_playlist.nix')
-rw-r--r--makefu/2configs/ham/multi/the_playlist.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/makefu/2configs/ham/multi/the_playlist.nix b/makefu/2configs/ham/multi/the_playlist.nix
new file mode 100644
index 00000000..aa5ce85d
--- /dev/null
+++ b/makefu/2configs/ham/multi/the_playlist.nix
@@ -0,0 +1,26 @@
+{
+ sensor = [
+ { platform = "rest";
+ name = "pl";
+ resource = "http://prism.r:8001/current";
+ scan_interval = 30;
+ json_attributes = [ "name" "filename" "youtube" ];
+ }
+ { platform = "template";
+ sensors = {
+ the_playlist_song = {
+ friendly_name = "Current Song";
+ value_template = ''{{ states.sensor.pl.attributes['name'] }}'';
+ };
+ the_playlist_url = {
+ friendly_name = "Song Youtube URL";
+ value_template = ''{{ states.sensor.pl.attributes['youtube'] }}'';
+ };
+ the_playlist_filename = {
+ friendly_name = "Song Filename";
+ value_template = ''{{ states.sensor.pl.attributes['filename'] }}'';
+ };
+ };
+ }
+ ];
+}