summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/git/brain-retiolum.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-06-07 03:14:21 +0200
committertv <tv@krebsco.de>2016-06-07 22:38:38 +0200
commit4a34b27c1c6c3fea2b336c0316c597d74460b428 (patch)
tree97b718fe06acba0f298a78207ed9a5cbfd542b1e /makefu/2configs/git/brain-retiolum.nix
parent6fcc35afb0003f0885994b3c09e401f3178d7a08 (diff)
krebs.git.cgit: make `cache-root` configurable
... along with all the other stuff :)
Diffstat (limited to 'makefu/2configs/git/brain-retiolum.nix')
-rw-r--r--makefu/2configs/git/brain-retiolum.nix14
1 files changed, 6 insertions, 8 deletions
diff --git a/makefu/2configs/git/brain-retiolum.nix b/makefu/2configs/git/brain-retiolum.nix
index 80e4c87c..ae54c6db 100644
--- a/makefu/2configs/git/brain-retiolum.nix
+++ b/makefu/2configs/git/brain-retiolum.nix
@@ -7,9 +7,7 @@ let
rules = concatMap krebs-rules (attrValues krebs-repos) ++ concatMap priv-rules (attrValues priv-repos);
krebs-repos = mapAttrs make-krebs-repo {
- brain = {
- desc = "braiiiins";
- };
+ brain = { };
};
priv-repos = mapAttrs make-priv-repo {
@@ -18,13 +16,13 @@ let
};
# TODO move users to separate module
- make-priv-repo = name: { desc ? null, ... }: {
- inherit name desc;
+ make-priv-repo = name: { ... }: {
+ inherit name;
public = false;
};
- make-krebs-repo = with git; name: { desc ? null, ... }: {
- inherit name desc;
+ make-krebs-repo = with git; name: { ... }: {
+ inherit name;
public = false;
hooks = {
post-receive = pkgs.git-hooks.irc-announce {
@@ -63,7 +61,7 @@ in {
imports = [ ];
krebs.git = {
enable = true;
- cgit = false;
+ cgit.enable = false;
inherit repos rules;
};
}