summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/mycube.connector.one.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-01-28 18:07:02 +0100
committerlassulus <lassulus@lassul.us>2021-01-28 18:07:02 +0100
commit10a397b299698f94561115e8239ed0cd8877c0fe (patch)
tree5a58fe88ab8551763818a400f6ebbbd7c69c56ea /makefu/2configs/deployment/mycube.connector.one.nix
parent549f3fd553155412f04870a31849b29776a63d59 (diff)
parent0ea65cef9aa2f936f357c624fc53a393f79d8fcc (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/deployment/mycube.connector.one.nix')
-rw-r--r--makefu/2configs/deployment/mycube.connector.one.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/makefu/2configs/deployment/mycube.connector.one.nix b/makefu/2configs/deployment/mycube.connector.one.nix
index 379176f7..aa9ff514 100644
--- a/makefu/2configs/deployment/mycube.connector.one.nix
+++ b/makefu/2configs/deployment/mycube.connector.one.nix
@@ -1,15 +1,12 @@
{ config, lib, pkgs, ... }:
# more than just nginx config but not enough to become a module
-with import <stockholm/lib>;
let
hostname = config.krebs.build.host.name;
external-ip = config.krebs.build.host.nets.internet.ip4.addr;
wsgi-sock = "${config.services.uwsgi.runDir}/uwsgi.sock";
in {
- services.redis = {
- enable = true;
- };
- systemd.services.redis.serviceConfig.LimitNOFILE=10032;
+ services.redis = { enable = true; };
+ systemd.services.redis.serviceConfig.LimitNOFILE=65536;
services.uwsgi = {
enable = true;
@@ -28,7 +25,7 @@ in {
};
services.nginx = {
- enable = mkDefault true;
+ enable = lib.mkDefault true;
virtualHosts."mybox.connector.one" = {
locations = {
"/".extraConfig = ''