summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/switch/rfbridge.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-04-04 09:50:16 +0200
committermakefu <github@syntax-fehler.de>2019-04-04 09:50:16 +0200
commitdf60cdea0a5beb2df8046bc85b8789862ee8c040 (patch)
tree0d29319ef3bb162591e8fbc9a9e68b854d8c9781 /makefu/2configs/bureautomation/switch/rfbridge.nix
parentbce8dd2348af3f15a6fe3c9cb91b5b7576c2bf99 (diff)
ma bureautomation: remove faulty motion detector
Diffstat (limited to 'makefu/2configs/bureautomation/switch/rfbridge.nix')
-rw-r--r--makefu/2configs/bureautomation/switch/rfbridge.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/switch/rfbridge.nix b/makefu/2configs/bureautomation/switch/rfbridge.nix
new file mode 100644
index 00000000..1336549a
--- /dev/null
+++ b/makefu/2configs/bureautomation/switch/rfbridge.nix
@@ -0,0 +1,17 @@
+let
+ topic = "rfbridge";
+ bridge = name: payload_on: payload_off:
+ { platform = "mqtt";
+ inherit name payload_on payload_off;
+ command_topic = "/bam/${topic}/cmnd/rfcode";
+ availability_topic = "/bam/${topic}/tele/LWT";
+ payload_available= "Online";
+ payload_not_available= "Offline";
+ };
+in
+[
+ (bridge "Nachtlicht A" "#414551" "#414554")
+ (bridge "Nachtlicht B" "#415151" "#415154")
+ (bridge "Nachtlicht C" "#415451" "#415454")
+ (bridge "Nachtlicht D" "#41551F" "#415514")
+]