summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/light/statuslight.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2019-11-12 19:18:31 +0100
committertv <tv@krebsco.de>2019-11-12 19:18:31 +0100
commiteaefd713c281e8802e4ff902b35a17b8b39f2b16 (patch)
treeed7521ae3c0c49dce87045c213618179042174ae /makefu/2configs/bureautomation/light/statuslight.nix
parent46cdc3ed4238965553d734b614b212fd96cba447 (diff)
parent4b5e3cbc6155ee807a9b6c474972df3e4fcd237b (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/2configs/bureautomation/light/statuslight.nix')
-rw-r--r--makefu/2configs/bureautomation/light/statuslight.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/makefu/2configs/bureautomation/light/statuslight.nix b/makefu/2configs/bureautomation/light/statuslight.nix
index 31f52f49..c9d30175 100644
--- a/makefu/2configs/bureautomation/light/statuslight.nix
+++ b/makefu/2configs/bureautomation/light/statuslight.nix
@@ -24,13 +24,13 @@ let
brightness_command_topic = "/bam/${topic}/cmnd/Dimmer";
brightness_scale = 100;
# color
- rgb_state_topic = "/bam/${topic}/stat/Color";
+ rgb_state_topic = "/bam/${topic}/stat/RESULT";
rgb_command_topic = "/bam/${topic}/cmnd/Color2";
- rgb_command_mode = "hex";
- rgb_command_template = "{{ '%02x%02x%02x' | format(red, green, blue)}}";
+ rgb_value_template = "{{(value_json.Channel[0]*2.55)|int}},{{(value_json.Channel[1]*2.55)|int}},{{(value_json.Channel[2]*2.55)|int}}";
+
# effects
effect_state_topic = "/bam/${topic}/tele/STATE";
- effects_value_template = "{{value_json.Scheme|default(0)}}";
+ effect_value_template = "{{value_json.Scheme|default(0)}}";
effect_command_topic = "/bam/${topic}/cmnd/Scheme";
effect_list = [
0 # single color for LED light