summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/light/statuslight.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-10-30 08:01:44 +0100
committerJeschli <jeschli@gmail.com>2019-11-14 15:36:11 +0100
commit2ac3254bd9dd4357c4c3d2880f7a127d3ff9d77c (patch)
treecb307726229766667b7c97c78b9087e08f7a6ebd /makefu/2configs/bureautomation/light/statuslight.nix
parent3f5b67e68c1a78ef9f3c3c6499e48b4e00dc6c66 (diff)
ma bureautomation: fix all the regression, add openwrt-luci-rpc as dependency
Diffstat (limited to 'makefu/2configs/bureautomation/light/statuslight.nix')
-rw-r--r--makefu/2configs/bureautomation/light/statuslight.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/makefu/2configs/bureautomation/light/statuslight.nix b/makefu/2configs/bureautomation/light/statuslight.nix
index 31f52f49..c9d30175 100644
--- a/makefu/2configs/bureautomation/light/statuslight.nix
+++ b/makefu/2configs/bureautomation/light/statuslight.nix
@@ -24,13 +24,13 @@ let
brightness_command_topic = "/bam/${topic}/cmnd/Dimmer";
brightness_scale = 100;
# color
- rgb_state_topic = "/bam/${topic}/stat/Color";
+ rgb_state_topic = "/bam/${topic}/stat/RESULT";
rgb_command_topic = "/bam/${topic}/cmnd/Color2";
- rgb_command_mode = "hex";
- rgb_command_template = "{{ '%02x%02x%02x' | format(red, green, blue)}}";
+ rgb_value_template = "{{(value_json.Channel[0]*2.55)|int}},{{(value_json.Channel[1]*2.55)|int}},{{(value_json.Channel[2]*2.55)|int}}";
+
# effects
effect_state_topic = "/bam/${topic}/tele/STATE";
- effects_value_template = "{{value_json.Scheme|default(0)}}";
+ effect_value_template = "{{value_json.Scheme|default(0)}}";
effect_command_topic = "/bam/${topic}/cmnd/Scheme";
effect_list = [
0 # single color for LED light