summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/hass.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-01-22 16:36:46 +0100
committerlassulus <lassulus@lassul.us>2019-01-22 16:36:46 +0100
commitd619bcbf4aa9b71c14b330efcfeea4fa94fa8573 (patch)
tree5a9bd58573336e717dc8b6d25fcaf3e24d9ed3c6 /makefu/2configs/bureautomation/hass.nix
parente14abf9583a2605eb3fad186cfef1a5ec11beb7f (diff)
parentb8bd543a79684d1c63a06fe5c1784d75e6dbbf85 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/bureautomation/hass.nix')
-rw-r--r--makefu/2configs/bureautomation/hass.nix19
1 files changed, 7 insertions, 12 deletions
diff --git a/makefu/2configs/bureautomation/hass.nix b/makefu/2configs/bureautomation/hass.nix
index a89a4813..57184bdf 100644
--- a/makefu/2configs/bureautomation/hass.nix
+++ b/makefu/2configs/bureautomation/hass.nix
@@ -3,19 +3,14 @@ let
tasmota_plug = name: topic:
{ platform = "mqtt";
inherit name;
- state_topic = "/bam/${topic}/stat/POWER1";
- command_topic = "/bam/${topic}/cmnd/POWER1";
+ state_topic = "/bam/${topic}/stat/POWER";
+ command_topic = "/bam/${topic}/cmnd/POWER";
availability_topic = "/bam/${topic}/tele/LWT";
payload_on= "ON";
payload_off= "OFF";
payload_available= "Online";
payload_not_available= "Offline";
};
- tasmota_stecki = name: topic:
- ( tasmota_plug name topic) //
- { state_topic = "/bam/${topic}/stat/POWER";
- command_topic = "/bam/${topic}/cmnd/POWER";
- };
espeasy_dht22 = name: [
{ platform = "mqtt";
name = "${name} DHT22 Temperature";
@@ -77,8 +72,8 @@ in {
switch = [
(tasmota_plug "Bauarbeiterlampe" "plug")
(tasmota_plug "Blitzdings" "plug2")
- (tasmota_stecki "Fernseher" "fernseher")
- (tasmota_plug "Pluggy" "plug4")
+ (tasmota_plug "Fernseher" "plug3")
+ (tasmota_plug "Feuer" "plug4")
];
binary_sensor = [
{ platform = "mqtt";
@@ -179,7 +174,7 @@ in {
"switch.bauarbeiterlampe"
"switch.blitzdings"
"switch.fernseher"
- "switch.pluggy"
+ "switch.feuer"
];
camera = [
"camera.Baumarkt"
@@ -212,7 +207,7 @@ in {
};
action = {
service = "homeassistant.turn_on";
- entity_id = [ "switch.fernseher" "switch.blitzdings" ];
+ entity_id = [ "switch.fernseher" "switch.feuer" ];
};
}
{ alias = "Turn off Fernseher 10 minutes after last movement";
@@ -231,7 +226,7 @@ in {
];
action = {
service = "homeassistant.turn_off";
- entity_id = [ "switch.fernseher" "switch.blitzdings" ];
+ entity_id = [ "switch.fernseher" "switch.feuer" ];
};
condition =
{ condition = "and";