summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/deps/openwrt-luci-rpc.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-10-30 08:01:44 +0100
committerJeschli <jeschli@gmail.com>2019-11-14 15:36:11 +0100
commit2ac3254bd9dd4357c4c3d2880f7a127d3ff9d77c (patch)
treecb307726229766667b7c97c78b9087e08f7a6ebd /makefu/2configs/bureautomation/deps/openwrt-luci-rpc.nix
parent3f5b67e68c1a78ef9f3c3c6499e48b4e00dc6c66 (diff)
ma bureautomation: fix all the regression, add openwrt-luci-rpc as dependency
Diffstat (limited to 'makefu/2configs/bureautomation/deps/openwrt-luci-rpc.nix')
-rw-r--r--makefu/2configs/bureautomation/deps/openwrt-luci-rpc.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/deps/openwrt-luci-rpc.nix b/makefu/2configs/bureautomation/deps/openwrt-luci-rpc.nix
new file mode 100644
index 00000000..4eceeb14
--- /dev/null
+++ b/makefu/2configs/bureautomation/deps/openwrt-luci-rpc.nix
@@ -0,0 +1,34 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, click
+, requests
+, packaging
+}:
+
+buildPythonPackage rec {
+ pname = "openwrt-luci-rpc";
+ version = "1.1.2";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "174a1f6c0bb2a2ed76e5299d14e2be05c612e8bcd4c15b9a9aedee1ef8e18b90";
+ };
+
+ patchPhase = ''
+ sed -i -e "s/requests==2.21.0/requests/" -e "s/packaging==19.1/packaging/" setup.py
+ '';
+
+ propagatedBuildInputs = [
+ click
+ requests
+ packaging
+ ];
+
+ meta = with lib; {
+ description = "Module for interacting with OpenWrt Luci RPC interface";
+ homepage = https://github.com/fbradyirl/openwrt-luci-rpc;
+ license = licenses.asl20;
+ maintainers = [ maintainers.makefu ];
+ };
+}