summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/brother-ql-web.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-06-19 03:25:39 +0200
committerlassulus <git@lassul.us>2023-06-19 03:25:39 +0200
commit139799c53cdaf55c362109e01be9dd96cc8700ed (patch)
treeb1ce719ec8f62458bce2d9fe2191b8d004630f2a /makefu/2configs/bureautomation/brother-ql-web.nix
parentcb8fbb09127392a17d698d91f78ede7ae46accb8 (diff)
parenta766e88e7c8d87aa6bdbde796d3a454f7b5e546e (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/bureautomation/brother-ql-web.nix')
-rw-r--r--makefu/2configs/bureautomation/brother-ql-web.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/brother-ql-web.nix b/makefu/2configs/bureautomation/brother-ql-web.nix
new file mode 100644
index 00000000..26887db0
--- /dev/null
+++ b/makefu/2configs/bureautomation/brother-ql-web.nix
@@ -0,0 +1,23 @@
+ {pkgs, ... }:
+ let
+ pkg = pkgs.brother_ql_web;
+ in {
+ systemd.services.brother-ql-web = {
+ after = [ "network.target" ];
+ description = "Brother QL Web Interface";
+ wantedBy = [ "multi-user.target" ];
+ environment = {
+ FLASK_PRINTER = "usb://0x04f9:0x209b/000F1Z401759";
+ FLASK_MODEL = "QL-800";
+ #FLASK_SERVER_PORT = "8013";
+ #FLASK_LABEL_DEFAULT_SIZE = "d24";
+ #FLASK_LABEL_DEFAULT_QR_SIZE = "7";
+ };
+ serviceConfig = {
+ ExecStart = "${pkg}/bin/brother_ql_web";
+ DynamicUser = true;
+ SupplementaryGroups = "lp";
+ Restart = "always";
+ };
+ };
+}