summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/x/x13/zfs.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-01-28 18:07:02 +0100
committerlassulus <lassulus@lassul.us>2021-01-28 18:07:02 +0100
commit10a397b299698f94561115e8239ed0cd8877c0fe (patch)
tree5a58fe88ab8551763818a400f6ebbbd7c69c56ea /makefu/1systems/x/x13/zfs.nix
parent549f3fd553155412f04870a31849b29776a63d59 (diff)
parent0ea65cef9aa2f936f357c624fc53a393f79d8fcc (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/1systems/x/x13/zfs.nix')
-rw-r--r--makefu/1systems/x/x13/zfs.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/makefu/1systems/x/x13/zfs.nix b/makefu/1systems/x/x13/zfs.nix
new file mode 100644
index 00000000..adfebbf9
--- /dev/null
+++ b/makefu/1systems/x/x13/zfs.nix
@@ -0,0 +1,32 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "nvme" "ehci_pci" "xhci_pci" "rtsx_pci_sdmmc" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "zroot/root/nixos";
+ fsType = "zfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/20BF-2755";
+ fsType = "vfat";
+ };
+
+ fileSystems."/home" =
+ { device = "zroot/root/home";
+ fsType = "zfs";
+ };
+
+ swapDevices = [ ];
+}