summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/gum/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-12-28 16:03:38 +0100
committermakefu <github@syntax-fehler.de>2017-12-28 16:03:38 +0100
commit6f150a4ab47f037c1b8ec5e8d1675d86b0738155 (patch)
treeabdca4f33cfbcfdea2f61d847947c7c5e4e90d8c /makefu/1systems/gum/config.nix
parent14634592a67b874d3fe9b47efd0d06aca72f5e5e (diff)
ma gum.r: use wireguard, vpnws
Diffstat (limited to 'makefu/1systems/gum/config.nix')
-rw-r--r--makefu/1systems/gum/config.nix26
1 files changed, 16 insertions, 10 deletions
diff --git a/makefu/1systems/gum/config.nix b/makefu/1systems/gum/config.nix
index b66ef1ab..4981872c 100644
--- a/makefu/1systems/gum/config.nix
+++ b/makefu/1systems/gum/config.nix
@@ -48,9 +48,14 @@ in {
<stockholm/makefu/2configs/share/gum.nix>
# <stockholm/makefu/2configs/sabnzbd.nix>
<stockholm/makefu/2configs/torrent.nix>
- <stockholm/makefu/2configs/iodined.nix>
+
+ # network
<stockholm/makefu/2configs/vpn/openvpn-server.nix>
+ <stockholm/makefu/2configs/vpn/vpnws/server.nix>
<stockholm/makefu/2configs/dnscrypt/server.nix>
+ <stockholm/makefu/2configs/iodined.nix>
+
+ # buildbot
<stockholm/makefu/2configs/remote-build/slave.nix>
## Web
@@ -103,15 +108,16 @@ in {
#}
{ # wireguard server
networking.firewall.allowedUDPPorts = [ 51820 ];
- #networking.wireguard.interfaces.wg0 = {
- # ips = [ "10.244.0.1/24" ];
- # privateKeyFile = (toString <secrets>) + "/wireguard.key";
- # allowedIPsAsRoutes = true;
- # peers = [{
- # allowedIPs = [ "0.0.0.0/0" "::/0" ];
- # publicKey = "fe5smvKVy5GAn7EV4w4tav6mqIAKhGWQotm7dRuRt1g=";
- # }];
- #};
+ networking.wireguard.interfaces.wg0 = {
+ ips = [ "10.244.0.1/24" ];
+ privateKeyFile = (toString <secrets>) + "/wireguard.key";
+ allowedIPsAsRoutes = true;
+ peers = [{
+ # allowedIPs = [ "0.0.0.0/0" "::/0" ];
+ allowedIPs = [ "10.244.0.2/32" ];
+ publicKey = "fe5smvKVy5GAn7EV4w4tav6mqIAKhGWQotm7dRuRt1g=";
+ }];
+ };
}
];