summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/cake/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-10-08 22:21:16 +0200
committermakefu <github@syntax-fehler.de>2017-10-08 22:21:16 +0200
commitf7f1d7a4462a801f23c3483fb1c3d2a4130a5240 (patch)
treee7a88bf662ff86a2b4104e63764fa4e30c79c8bb /makefu/1systems/cake/config.nix
parente230eaa0a22d1f23e3f53a62d113d2889be32598 (diff)
ma cake.r: add firmware for wifi
Diffstat (limited to 'makefu/1systems/cake/config.nix')
-rw-r--r--makefu/1systems/cake/config.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/makefu/1systems/cake/config.nix b/makefu/1systems/cake/config.nix
index 35eac3ab..e8438e50 100644
--- a/makefu/1systems/cake/config.nix
+++ b/makefu/1systems/cake/config.nix
@@ -22,6 +22,20 @@
boot.tmpOnTmpfs = lib.mkForce false;
hardware.enableRedistributableFirmware = true;
+ hardware.firmware = [
+ (pkgs.stdenv.mkDerivation {
+ name = "broadcom-rpi3-rest";
+ src = pkgs.fetchurl {
+ url = "https://raw.githubusercontent.com/RPi-Distro/firmware-nonfree/54bab3d/brcm80211/brcm/brcmfmac43430-sdio.txt";
+ sha256 = "19bmdd7w0xzybfassn7x4rb30l70vynnw3c80nlapna2k57xwbw7";
+ };
+ phases = [ "installPhase" ];
+ installPhase = ''
+ mkdir -p $out/lib/firmware/brcm
+ cp $src $out/lib/firmware/brcm/brcmfmac43430-sdio.txt
+ '';
+ })
+ ];
networking.wireless.enable = true;
# File systems configuration for using the installer's partition layout