summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-04-02 19:38:35 +0200
committerjeschli <jeschli@gmail.com>2019-04-02 19:38:35 +0200
commitf8b88080d5bb27e4a6b35b26d6036de40517ba57 (patch)
treef8a077997ca889950daa0cb5ec11cc486f420bbe /lib/types.nix
parent17712c90772d68f174f579e570fa23a8fa674245 (diff)
parent6654f03b09b7b80e3ee6339c92e6172579349744 (diff)
:Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 17c1688f..9001bc7c 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -86,6 +86,12 @@ rec {
type = nullOr ssh-privkey;
default = null;
};
+
+ syncthing.id = mkOption {
+ # TODO syncthing id type
+ type = nullOr string;
+ default = null;
+ };
};
});
@@ -539,7 +545,7 @@ rec {
# POSIX.1‐2013, 3.278 Portable Filename Character Set
filename = mkOptionType {
name = "POSIX filename";
- check = test "([0-9A-Za-z._])[0-9A-Za-z._-]*";
+ check = test "[0-9A-Za-z._][0-9A-Za-z._-]*";
merge = mergeOneOption;
};