summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-04-22 00:30:37 +0200
committermakefu <github@syntax-fehler.de>2020-04-22 00:30:37 +0200
commitcb7ea9d84af46b606e5daa1252c60eb210d7e576 (patch)
tree5166a62dc73c45b3cd3b996078913588d1844266 /lib/default.nix
parent0b371833e9ef68fd891fac65a657d8e38b5b3fad (diff)
parentc49867b40327f83a18b956404875637ca379c1ba (diff)
Merge remote-tracking branch 'lass/20.03' into 20.03
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 14e6e27a..5a948bbf 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -49,6 +49,8 @@ let
indent = replaceChars ["\n"] ["\n "];
+ stripAttr = converge (filterAttrsRecursive (n: v: v != {} && v != null));
+
mapNixDir = f: x: {
list = foldl' mergeAttrs {} (map (mapNixDir1 f) x);
path = mapNixDir1 f x;