summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-04-21 21:50:59 +0200
committermakefu <github@syntax-fehler.de>2020-04-21 21:50:59 +0200
commitc96504d9a0f8f9f5c80c9630906c177ff3667e55 (patch)
tree7b763ca595967bfcc5d8307751091f373fd38e47 /lib/default.nix
parent4fc2235ab0a8a11ea21965c86e5ba17279384db4 (diff)
parentcabaf519b5970cbe5c1e57832d3bd12da4f47371 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 14e6e27a..5a948bbf 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -49,6 +49,8 @@ let
indent = replaceChars ["\n"] ["\n "];
+ stripAttr = converge (filterAttrsRecursive (n: v: v != {} && v != null));
+
mapNixDir = f: x: {
list = foldl' mergeAttrs {} (map (mapNixDir1 f) x);
path = mapNixDir1 f x;