summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-02-26 08:58:51 +0100
committermakefu <github@syntax-fehler.de>2019-02-26 08:58:51 +0100
commite437c7d17b4accf9c18d2aa17a0ec98a171d8f3f (patch)
treebbb65961d3eaaa7f14461383290db99f391bb6cb /lib/default.nix
parent6da32a5952faf38c92c7b289cc6ae0881ec4aa36 (diff)
parent2db5d56cf2e252822f38900ef9436d7b118476a9 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 347830e8..8ba55b57 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -9,6 +9,7 @@ let
krops = import ../submodules/krops/lib;
shell = import ./shell.nix { inherit lib; };
types = nixpkgs-lib.types // import ./types.nix { inherit lib; };
+ xml = import ./xml.nix { inherit lib; };
eq = x: y: x == y;
ne = x: y: x != y;
@@ -145,6 +146,11 @@ let
in
filter (x: x != []) ([acc.chunk] ++ acc.chunks);
+ warnOldVersion = oldName: newName:
+ if compareVersions oldName newName != -1 then
+ trace "Upstream `${oldName}' gets overridden by `${newName}'." newName
+ else
+ newName;
};
in