summaryrefslogtreecommitdiffstats
path: root/lass/krops.nix
diff options
context:
space:
mode:
authorlassulus <lass@blue.r>2018-10-23 15:45:38 +0200
committerlassulus <lass@blue.r>2018-10-23 15:45:38 +0200
commitfc799f61f17014e61f5bd602c5e44f7412660c28 (patch)
treeea5ac7f06e2b3370f029c858a3dbccaf1d16f530 /lass/krops.nix
parent153648682697aafe89ef7eb69805ae8e6a25bc39 (diff)
l krops: add optional target argument to deploy
Diffstat (limited to 'lass/krops.nix')
-rw-r--r--lass/krops.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lass/krops.nix b/lass/krops.nix
index 13b10e25..a898164c 100644
--- a/lass/krops.nix
+++ b/lass/krops.nix
@@ -22,9 +22,9 @@
in {
# usage: $(nix-build --no-out-link --argstr name HOSTNAME -A deploy)
- deploy = pkgs.krops.writeDeploy "${name}-deploy" {
+ deploy = { target ? "root@${name}/var/src" }: pkgs.krops.writeDeploy "${name}-deploy" {
source = source { test = false; };
- target = "root@${name}/var/src";
+ inherit target;
};
# usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)