summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/firefoxPlugins
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-09-26 12:12:50 +0200
committerlassulus <lass@aidsballs.de>2015-09-26 12:12:50 +0200
commit0d806f61d2709f0ff8bf03ee431839035215e689 (patch)
treecb8fda99b540ca280ef5b45319f8d79e786039b0 /lass/5pkgs/firefoxPlugins
parent895971f21490222e7d4060d5ec1a6bb4395ff595 (diff)
lass: add firefoxPatched + firefoxPlugins
Diffstat (limited to 'lass/5pkgs/firefoxPlugins')
-rw-r--r--lass/5pkgs/firefoxPlugins/noscript.nix28
l---------lass/5pkgs/firefoxPlugins/result1
-rw-r--r--lass/5pkgs/firefoxPlugins/ublock.nix31
-rw-r--r--lass/5pkgs/firefoxPlugins/vimperator.nix19
4 files changed, 79 insertions, 0 deletions
diff --git a/lass/5pkgs/firefoxPlugins/noscript.nix b/lass/5pkgs/firefoxPlugins/noscript.nix
new file mode 100644
index 00000000..67a00a1b
--- /dev/null
+++ b/lass/5pkgs/firefoxPlugins/noscript.nix
@@ -0,0 +1,28 @@
+{ fetchgit, stdenv, bash, zip }:
+
+stdenv.mkDerivation rec {
+ name = "noscript";
+ id = "{73a6fe31-595d-460b-a920-fcc0f8843232}";
+
+ src = fetchgit {
+ url = "https://github.com/avian2/noscript";
+ rev = "c900a079793868bb080ab1e23522d29dc121b4c6";
+ sha256 = "1y06gh5a622yrsx0h7v92qnvdi97i54ln09zc1lvk8x430z5bdly";
+ };
+
+ buildInputs = [ zip ];
+
+ patchPhase = ''
+ substituteInPlace "version.sh" \
+ --replace "/bin/bash" "${bash}/bin/bash"
+ '';
+
+ buildPhase = ''
+ ./makexpi.sh
+ '';
+
+ installPhase = ''
+ mkdir -p $out/
+ cp *.xpi $out/${id}.xpi
+ '';
+}
diff --git a/lass/5pkgs/firefoxPlugins/result b/lass/5pkgs/firefoxPlugins/result
new file mode 120000
index 00000000..aa533441
--- /dev/null
+++ b/lass/5pkgs/firefoxPlugins/result
@@ -0,0 +1 @@
+/nix/store/gxr152p1bbgqcd839b0rckdd1h5cr886-vimperator \ No newline at end of file
diff --git a/lass/5pkgs/firefoxPlugins/ublock.nix b/lass/5pkgs/firefoxPlugins/ublock.nix
new file mode 100644
index 00000000..29ef250e
--- /dev/null
+++ b/lass/5pkgs/firefoxPlugins/ublock.nix
@@ -0,0 +1,31 @@
+{ fetchgit, stdenv, bash, python, zip }:
+
+stdenv.mkDerivation rec {
+ name = "ublock";
+ id = "{2b10c1c8-a11f-4bad-fe9c-1c11e82cac42}";
+
+ src = fetchgit {
+ url = "https://github.com/chrisaljoudi/uBlock";
+ rev = "a70a50052a7914cbf86d46a725812b98434d8c70";
+ sha256 = "1qfzy79f8x01i33x0m95k833z1jgxjwb8wvlr6fj6id1kxfvzh77";
+ };
+
+ buildInputs = [
+ zip
+ python
+ ];
+
+ patchPhase = ''
+ substituteInPlace "tools/make-firefox.sh" \
+ --replace "/bin/bash" "${bash}/bin/bash"
+ '';
+
+ buildPhase = ''
+ tools/make-firefox.sh all
+ '';
+
+ installPhase = ''
+ mkdir -p $out/
+ cp dist/build/uBlock.firefox.xpi $out/${id}.xpi
+ '';
+}
diff --git a/lass/5pkgs/firefoxPlugins/vimperator.nix b/lass/5pkgs/firefoxPlugins/vimperator.nix
new file mode 100644
index 00000000..dabef3d2
--- /dev/null
+++ b/lass/5pkgs/firefoxPlugins/vimperator.nix
@@ -0,0 +1,19 @@
+{ fetchgit, stdenv, zip }:
+
+stdenv.mkDerivation rec {
+ name = "vimperator";
+ id = "vimperator@mozdev.org";
+
+ src = fetchgit {
+ url = "https://github.com/vimperator/vimperator-labs.git";
+ rev = "ba7d8e72516fdc22246748c8183d7bc90f6fb073";
+ sha256 = "0drz67qm5hxxzw699rswlpjkg4p2lfipx119pk1nyixrqblcsvq2";
+ };
+
+ buildInputs = [ zip ];
+
+ installPhase = ''
+ mkdir -p $out/
+ cp downloads/vimperator*.xpi $out/${id}.xpi
+ '';
+}