summaryrefslogtreecommitdiffstats
path: root/lass/2configs/tmux.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-11-07 14:31:25 +0100
committermakefu <github@syntax-fehler.de>2021-11-07 14:31:25 +0100
commit597f546e9833b2569ee6ec540f688f7fb95bd26c (patch)
treee7393bb0aea4faee24e85e63d82843bd3b9a0bac /lass/2configs/tmux.nix
parent9392c355ad5198346313ef0972db1910c10d17bf (diff)
parent0e668121a1388914f33a6546c2f63adc212a38c4 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/2configs/tmux.nix')
-rw-r--r--lass/2configs/tmux.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/lass/2configs/tmux.nix b/lass/2configs/tmux.nix
new file mode 100644
index 00000000..c977a110
--- /dev/null
+++ b/lass/2configs/tmux.nix
@@ -0,0 +1,46 @@
+with import <stockholm/lib>;
+{ config, pkgs, ... }:
+
+{
+ nixpkgs.config.packageOverrides = super: {
+ tmux = pkgs.symlinkJoin {
+ name = "tmux";
+ paths = [
+ (pkgs.writeDashBin "tmux" ''
+ exec ${super.tmux}/bin/tmux -f ${pkgs.writeText "tmux.conf" ''
+ #change prefix key to `
+ set-option -g prefix `
+ unbind-key C-b
+ bind ` send-prefix
+
+ set-option -g default-terminal screen-256color
+
+ #use session instead of windows
+ bind-key c new-session
+ bind-key p switch-client -p
+ bind-key n switch-client -n
+ bind-key C-s switch-client -l
+ ''} "$@"
+ '')
+ super.tmux
+ ];
+ };
+ };
+ environment.systemPackages = with pkgs; [
+ tmux
+ ];
+
+ # programs.bash.interactiveShellInit = ''
+ # if [[ "$TERM" != "linux" && -z "$TMUX" ]]; then
+ # if [[ -n "$SSH_AUTH_SOCK" ]]; then
+ # tmux set-environment -g SSH_AUTH_SOCK "$SSH_AUTH_SOCK" 2>/dev/null
+ # fi
+
+ # exec tmux -u
+ # fi
+ # if [[ "$__host__" != "$HOST" ]]; then
+ # tmux set -g status-bg colour$(string_hash $HOST 255)
+ # export __host__=$HOST
+ # fi
+ # '';
+}