summaryrefslogtreecommitdiffstats
path: root/lass/2configs/steam.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-07-28 20:28:21 +0200
committerlassulus <lass@aidsballs.de>2015-07-28 20:28:21 +0200
commitac64527c5707cca5fc6e6e6ecf3957129cdb32b2 (patch)
tree741d27e6ec9279b6bd42deec2b4023aedc1bd598 /lass/2configs/steam.nix
parentb5d5b75d7d6dcc42f69418e6a454a64502fa6aee (diff)
lass: port everything to stockholm
Diffstat (limited to 'lass/2configs/steam.nix')
-rw-r--r--lass/2configs/steam.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/lass/2configs/steam.nix b/lass/2configs/steam.nix
new file mode 100644
index 00000000..7d088fc6
--- /dev/null
+++ b/lass/2configs/steam.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, ... }:
+
+{
+
+ imports = [
+ ./games.nix
+ ];
+ #
+ # Steam stuff
+ # source: https://nixos.org/wiki/Talk:Steam
+ #
+ ##TODO: make steam module
+ hardware.opengl.driSupport32Bit = true;
+
+ nixpkgs.config.steam.java = true;
+ environment.systemPackages = with pkgs; [
+ steam
+ ];
+ networking.firewall = {
+ allowedUDPPorts = [
+ 27031
+ 27036
+ ];
+ allowedTCPPorts = [
+ 27036
+ 27037
+ ];
+ };
+
+}