summaryrefslogtreecommitdiffstats
path: root/lass/2configs/steam.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-09-05 11:56:49 +0200
committerlassulus <lass@aidsballs.de>2015-09-05 11:56:49 +0200
commit29c5c4913157445c467cd9b6d525830bdbb15116 (patch)
tree62d9fd433995e35d0c847465f296febe8bfc618f /lass/2configs/steam.nix
parent954f122d383ad18c68fcfb9497727bec9746166d (diff)
lass 2 steam: move config to new firewall
Diffstat (limited to 'lass/2configs/steam.nix')
-rw-r--r--lass/2configs/steam.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/lass/2configs/steam.nix b/lass/2configs/steam.nix
index 7d088fc6..bd895e15 100644
--- a/lass/2configs/steam.nix
+++ b/lass/2configs/steam.nix
@@ -16,15 +16,14 @@
environment.systemPackages = with pkgs; [
steam
];
- networking.firewall = {
- allowedUDPPorts = [
- 27031
- 27036
- ];
- allowedTCPPorts = [
- 27036
- 27037
- ];
+ lass.iptables = {
+ tables = {
+ filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 27031"; target = "ACCEPT"; }
+ { predicate = "-p tcp --dport 27036"; target = "ACCEPT"; }
+ { predicate = "-p udp --dport 27031"; target = "ACCEPT"; }
+ { predicate = "-p udp --dport 27036"; target = "ACCEPT"; }
+ ];
+ };
};
-
}