summaryrefslogtreecommitdiffstats
path: root/lass/2configs/ppp/x220-modem.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2021-01-25 11:28:26 +0100
committertv <tv@krebsco.de>2021-01-25 11:28:26 +0100
commita0ca091cbf4e9ca41390ad9d54844c9eb2660406 (patch)
treeaae89f223f953a81da400d6f7deac1d5ae5d240e /lass/2configs/ppp/x220-modem.nix
parent1cd73df0c8694f491d40f93a796ea58f150e88dc (diff)
parent71206dc6a2852dd69664e85aa6dcb49676ec1f6e (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'lass/2configs/ppp/x220-modem.nix')
-rw-r--r--lass/2configs/ppp/x220-modem.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/lass/2configs/ppp/x220-modem.nix b/lass/2configs/ppp/x220-modem.nix
new file mode 100644
index 00000000..d6facb72
--- /dev/null
+++ b/lass/2configs/ppp/x220-modem.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }: {
+
+ # usage: pppd call x220
+
+ environment.etc."ppp/peers/x220".text = ''
+ /dev/ttyACM2
+ 921600
+ crtscts
+ defaultroute
+ holdoff 10
+ lock
+ maxfail 0
+ noauth
+ nodetach
+ noipdefault
+ passive
+ persist
+ usepeerdns
+ connect "${pkgs.ppp}/bin/chat -f ${pkgs.writeText "default.chat" ''
+ ABORT "BUSY"
+ ABORT "NO CARRIER"
+ REPORT CONNECT
+ "" "ATDT*99#"
+ CONNECT
+ ''}"
+ '';
+
+ environment.systemPackages = [
+ pkgs.ppp
+ ];
+
+}