summaryrefslogtreecommitdiffstats
path: root/lass/2configs/livestream.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-03-04 19:49:39 +0100
committerlassulus <lass@lassul.us>2017-03-04 19:49:39 +0100
commitdd30ebef45b63b4c8bb8b586f750ff877f60f565 (patch)
treec1e6d5744af7188a70df1d5d568dbd129bee16aa /lass/2configs/livestream.nix
parentcf289c9aec98fcb87e1debeb48f991f0256cdbb1 (diff)
l 2: add livestream.nix
Diffstat (limited to 'lass/2configs/livestream.nix')
-rw-r--r--lass/2configs/livestream.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/lass/2configs/livestream.nix b/lass/2configs/livestream.nix
new file mode 100644
index 00000000..25d54e26
--- /dev/null
+++ b/lass/2configs/livestream.nix
@@ -0,0 +1,12 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+
+let
+
+ stream = pkgs.writeDashBin "stream" ''
+ ${pkgs.python35Packages.livestreamer}/bin/livestreamer --http-header Client-ID=jzkbprff40iqj646a697cyrvl0zt2m6 -p mpv "$@"
+ '';
+
+in {
+ environment.systemPackages = [ stream ];
+}