summaryrefslogtreecommitdiffstats
path: root/lass/2configs/htop.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-03-07 22:57:21 +0100
committerlassulus <lass@lassul.us>2017-03-07 22:57:21 +0100
commitf66d7f4d4720d1166520eae6a552245bc92e6a2d (patch)
tree434c6c07f6af4704f0b75b056f7a99c8d65eb105 /lass/2configs/htop.nix
parent6a9ff979548fdc28193569b0e514353838c87896 (diff)
l 2: add htop.nix
Diffstat (limited to 'lass/2configs/htop.nix')
-rw-r--r--lass/2configs/htop.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/lass/2configs/htop.nix b/lass/2configs/htop.nix
new file mode 100644
index 00000000..0296101a
--- /dev/null
+++ b/lass/2configs/htop.nix
@@ -0,0 +1,40 @@
+{ pkgs, ... }:
+
+with import <stockholm/lib>;
+
+{
+ nixpkgs.config.packageOverrides = super: {
+ htop = pkgs.concat "htop" [
+ super.htop
+ (pkgs.writeDashBin "htop" ''
+ export HTOPRC=${pkgs.writeText "htoprc" ''
+ fields=0 48 17 18 38 39 40 2 46 47 49 1
+ sort_key=46
+ sort_direction=1
+ hide_threads=0
+ hide_kernel_threads=1
+ hide_userland_threads=0
+ shadow_other_users=1
+ show_thread_names=1
+ show_program_path=1
+ highlight_base_name=1
+ highlight_megabytes=1
+ highlight_threads=1
+ tree_view=1
+ header_margin=1
+ detailed_cpu_time=0
+ cpu_count_from_zero=0
+ update_process_names=0
+ account_guest_in_cpu_meter=1
+ color_scheme=6
+ delay=15
+ left_meters=LeftCPUs2 RightCPUs2 Memory Swap
+ left_meter_modes=1 1 1 1
+ right_meters=Uptime Tasks LoadAverage Battery
+ right_meter_modes=2 2 2 2
+ ''}
+ exec ${super.htop}/bin/htop "$@"
+ '')
+ ];
+ };
+}