summaryrefslogtreecommitdiffstats
path: root/lass/2configs/hass/default.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-05-16 17:21:34 +0200
committerlassulus <lassulus@lassul.us>2020-05-16 17:21:34 +0200
commitcf5b35b2df428495f5bf4dd89e3cab190f069080 (patch)
tree6984419cbcdf81036a40ded9222b525b72bc9857 /lass/2configs/hass/default.nix
parentf9c0888a4d63fb04a2d282eb25cf0fa3d3c9ac42 (diff)
l hass: add more rooms & automations
Diffstat (limited to 'lass/2configs/hass/default.nix')
-rw-r--r--lass/2configs/hass/default.nix26
1 files changed, 23 insertions, 3 deletions
diff --git a/lass/2configs/hass/default.nix b/lass/2configs/hass/default.nix
index ef936110..639ba3d3 100644
--- a/lass/2configs/hass/default.nix
+++ b/lass/2configs/hass/default.nix
@@ -1,8 +1,12 @@
{ config, lib, pkgs, ... }:
+with import ./lib.nix { inherit lib; };
+
{
imports = [
./zigbee.nix
./rooms/bett.nix
+ ./rooms/essen.nix
+ ./rooms/nass.nix
];
krebs.iptables.tables.filter.INPUT.rules = [
@@ -33,9 +37,11 @@
homeassistant = {
name = "Home";
time_zone = "Europe/Berlin";
- latitude = "48.7687";
- longitude = "9.2478";
- elevation = 247;
+ latitude = "52.46187";
+ longitude = "13.41489";
+ elevation = 90;
+ unit_system = "metric";
+ customize = friendly_names;
};
config = {};
sun.elevation = 66;
@@ -61,6 +67,10 @@
};
};
sensor = [
+ {
+ platform = "dwd_weather_warnings";
+ region_name = "Berlin";
+ }
];
switch = [
(tasmota_s20 "TV" "tv")
@@ -69,6 +79,16 @@
(tasmota_s20 "Stereo Anlage" "stereo")
];
mobile_app = {};
+ hue = {};
+ weather = [
+ {
+ platform = "openweathermap";
+ api_key = "xxx"; # TODO put into secrets
+ }
+ ];
+ system_health = {};
+ history = {};
+ shopping_list = {};
};
services.mosquitto = {