summaryrefslogtreecommitdiffstats
path: root/lass/2configs/git.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-17 14:53:14 +0200
committerlassulus <lassulus@lassul.us>2017-07-17 14:53:14 +0200
commit53f8fa81e58c426d2a88b1bba4bfc0524dcb9387 (patch)
tree8eba7b7a949ac8d85010e95da542087cf04f41fd /lass/2configs/git.nix
parentd2f766b1968fd431c4eb210e8d0753449b4af568 (diff)
l git: announce brain
Diffstat (limited to 'lass/2configs/git.nix')
-rw-r--r--lass/2configs/git.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/lass/2configs/git.nix b/lass/2configs/git.nix
index 4137c482..a66d0892 100644
--- a/lass/2configs/git.nix
+++ b/lass/2configs/git.nix
@@ -49,6 +49,7 @@ let
{
brain = {
collaborators = with config.krebs.users; [ tv makefu ];
+ announce = true;
};
} //
import <secrets/repos.nix> { inherit config lib pkgs; }
@@ -75,9 +76,20 @@ let
public = true;
};
- make-restricted-repo = name: { collaborators ? [], ... }: {
+ make-restricted-repo = name: { collaborators ? [], announce ? false, ... }: {
inherit collaborators name;
public = false;
+ hooks = optionalAttrs announce {
+ post-receive = pkgs.git-hooks.irc-announce {
+ # TODO make nick = config.krebs.build.host.name the default
+ nick = config.krebs.build.host.name;
+ channel = "#retiolum";
+ server = "ni.r";
+ verbose = true;
+ # TODO define branches in some kind of option per repo
+ branches = [ "master" "staging*" ];
+ };
+ };
};
make-rules =