summaryrefslogtreecommitdiffstats
path: root/lass/2configs/br.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-10-26 20:01:37 +0200
committerlassulus <lassulus@lassul.us>2017-10-26 20:01:37 +0200
commit8083880f49973eff49673da30b442f75b729594c (patch)
treec2c09d8dc6cc3cb827bff076ca03325e193b90df /lass/2configs/br.nix
parent45f205e1c5b7d5d1d45eab1fb293c86f7c93bd49 (diff)
l: steal br from tv
Diffstat (limited to 'lass/2configs/br.nix')
-rw-r--r--lass/2configs/br.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/lass/2configs/br.nix b/lass/2configs/br.nix
new file mode 100644
index 00000000..35bac8fe
--- /dev/null
+++ b/lass/2configs/br.nix
@@ -0,0 +1,48 @@
+with import <stockholm/lib>;
+{ config, pkgs, ... }: {
+
+ imports = [
+ <nixpkgs/nixos/modules/services/hardware/sane_extra_backends/brscan4.nix>
+ ];
+
+ krebs.nixpkgs.allowUnfreePredicate = pkg: any (flip hasPrefix pkg.name) [
+ "brother-udev-rule-type1-"
+ "brscan4-"
+ "mfcl2700dnlpr-"
+ ];
+
+ hardware.sane = {
+ enable = true;
+ brscan4 = {
+ enable = true;
+ netDevices = {
+ bra = {
+ model = "MFCL2700DN";
+ ip = "10.23.42.221";
+ };
+ };
+ };
+ };
+
+ services.saned.enable = true;
+
+ # usage: scanimage -d "$(find-scanner bra)" --batch --format=tiff --resolution 150 -x 211 -y 298
+ environment.systemPackages = [
+ (pkgs.writeDashBin "find-scanner" ''
+ set -efu
+ name=$1
+ ${pkgs.sane-backends}/bin/scanimage -f '%m %d
+ ' \
+ | ${pkgs.gawk}/bin/awk -v dev="*$name" '$1 == dev { print $2; exit }' \
+ | ${pkgs.gnugrep}/bin/grep .
+ '')
+ ];
+
+ services.printing = {
+ enable = true;
+ drivers = [
+ pkgs.mfcl2700dncupswrapper
+ ];
+ };
+
+}