summaryrefslogtreecommitdiffstats
path: root/lass/2configs/blue.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-05-20 10:20:10 +0200
committerlassulus <lassulus@lassul.us>2018-05-20 10:20:10 +0200
commitd72657a57be63ff6eeeaa0b84cd7761b2d38c8b4 (patch)
tree1f9f803fec5ceaac8a69ee7016ccca0b324181ae /lass/2configs/blue.nix
parentc7a49e7ac91eef1833992d9801b11febad726afe (diff)
l blue.r: add weechat, backups & mail
Diffstat (limited to 'lass/2configs/blue.nix')
-rw-r--r--lass/2configs/blue.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/lass/2configs/blue.nix b/lass/2configs/blue.nix
new file mode 100644
index 00000000..c0417b86
--- /dev/null
+++ b/lass/2configs/blue.nix
@@ -0,0 +1,55 @@
+with (import <stockholm/lib>);
+{ config, lib, pkgs, ... }:
+
+{
+
+ imports = [
+ ./bitlbee.nix
+ ./mail.nix
+ ./pass.nix
+ ];
+
+ services.tor.enable = true;
+
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-i retiolum -p udp --dport 60000:61000"; target = "ACCEPT";}
+ { predicate = "-i retiolum -p tcp --dport 9999"; target = "ACCEPT";}
+ ];
+
+ systemd.services.chat = let
+ tmux = pkgs.writeDash "tmux" ''
+ exec ${pkgs.tmux}/bin/tmux -f ${pkgs.writeText "tmux.conf" ''
+ set-option -g prefix `
+ unbind-key C-b
+ bind ` send-prefix
+
+ set-option -g status off
+ set-option -g default-terminal screen-256color
+
+ #use session instead of windows
+ bind-key c new-session
+ bind-key p switch-client -p
+ bind-key n switch-client -n
+ bind-key C-s switch-client -l
+ ''} "$@"
+ '';
+ in {
+ description = "chat environment setup";
+ after = [ "network.target" ];
+ wantedBy = [ "multi-user.target" ];
+
+ restartIfChanged = false;
+
+ path = [
+ pkgs.rxvt_unicode.terminfo
+ ];
+
+ serviceConfig = {
+ User = "lass";
+ RemainAfterExit = true;
+ Type = "oneshot";
+ ExecStart = "${tmux} -2 new-session -d -s IM ${pkgs.weechat}/bin/weechat";
+ ExecStop = "${tmux} kill-session -t IM";
+ };
+ };
+}