summaryrefslogtreecommitdiffstats
path: root/lass/2configs/blue-host.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-05-20 10:04:05 +0200
committerlassulus <lassulus@lassul.us>2018-05-20 10:04:05 +0200
commite1fec918a64a6c0aff0b758b4ea8a5e228623012 (patch)
tree2eab1386817468798e7498d6754e138a7fa13b57 /lass/2configs/blue-host.nix
parente437f49a1b604f92d875a1209b4e4f9f5b46c893 (diff)
l cabal.r: provice host for blue.r
Diffstat (limited to 'lass/2configs/blue-host.nix')
-rw-r--r--lass/2configs/blue-host.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/lass/2configs/blue-host.nix b/lass/2configs/blue-host.nix
new file mode 100644
index 00000000..657234bc
--- /dev/null
+++ b/lass/2configs/blue-host.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+
+{
+ imports = [
+ <stockholm/lass/2configs/container-networking.nix>
+ ];
+ containers.blue = {
+ config = { ... }: {
+ environment.systemPackages = [ pkgs.git ];
+ services.openssh.enable = true;
+ users.users.root.openssh.authorizedKeys.keys = [
+ config.krebs.users.lass.pubkey
+ ];
+ };
+ autoStart = true;
+ enableTun = true;
+ privateNetwork = true;
+ hostAddress = "10.233.2.9";
+ localAddress = "10.233.2.10";
+ };
+}